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RMRAccounts 
RMRAccounts Personal Accounts Suite is a comprehensive package with a fully integrated range 
of functions for managing your personal and home finances. The program consists of 5 screens 
directly accessible from the View menu and 5 Module screens accessible from a secondary menu. 
Note:  Swiping horizontally in the Accounts screen will move you to the Transactions screen and 
swiping in the Transaction screen will cycle through accounts, which seemed more logical. 

Accounts (Home screen): 

 This lists all of your bank, savings, credit or debit cards and other accounts with their balances, 
and shows your total worth. Accounts can be held in one or more Groups each of which can be 
operated in different currencies. 

Transactions: 

 Where you enter and record all your incoming and outgoing transactions for each account. 

Budget Categories: 

 To keep track of your outgoings by allocating transactions to Budget Categories, similar to those 
used in Quicken. 

Automated Payments: 

 To setup regular Automated Payments (aka Standing Orders, Direct Debits or Future 
Transactions) and estimated interest payments made to/from accounts. 

Archive: 

 Allows you to keep a permanent record of transactions after they have been reconciled and 
removed from the live accounts. 

Fuel: 

 Three screens that allow you to monitor your fuel consumption and expenses, and to setup 
reminders for things like insurance, safety checks, registrations. 

House: 

 Allows you to keep a permanent record of your Home contents for insurance valuation purposes. 

Planner: 

 Allows you to keep an annual budget record to predict future expenses.  

Invest: 

 Allows you to track a simple portfolio of PEPs/ISAs/Shares.  

Utilities: 

 Allows you to keep track of Electricity/Gas/Oil usage. 

Checklists: 

 Allows you to keep lists of anything. 
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Example Usage 

To demonstrate how I use the program (it was written with me in mind, as I have ‘lives’ in both the UK and 
the USA), here is my setup: 

I have defined 4 different groups: 

UK Personal     (using £) 
UK Savings      (using £) 
USA Personal  (using US$) 
Business          (using US$) 

In each of the first 3 groups I have my Current(Checking) Accounts, Credit Card, Mortgage  accounts and 
anything else I want to track  (I actually have a ‘dummy’ account for tracking Air Miles). 

Similarly I use 3 different Budget Category groups, UK, USA & Business.   The first 2 contain the usual Gas, 
Electricity, Oil, Car, Water, and the Business group has all my individual program so I can track my income 
from each one. 

The logic I use within the program is that I have only ‘unproven’ transactions in the main screen.  Once I 
have reconciled a set of payments with a statement (monthly/annually) then I can archive the reconciled 
transactions.  In fact the ONLY difference between a ‘live’ transaction and an ‘archived’ transaction is that 
you cannot edit an ‘archived’ entry. 

You can also use the Archive files in whatever way is convenient.  Personally I run three annual archives, 
on for my personal UK dealings, one for my personal USA dealings and one for the business dealings.  
Then on 1 Jan I restart with 3 new archives.  

I have my 4 cars (2 in the UK & 2 in the USA) entered here, with all the associated reminders. 

I have the contents of both my houses entered into 2 separate files 

I have a Budget Planner set up for each of the 2 houses as well. 

I use the Investment module to track my ISAs 

I use the Utility module to track Electricity, Gas, Water, Oil and Broadband usage.  

I use the Checklist module for holiday packing lists, action to close down house for the winter… 

I hope that explains one way to utilise the functionality of the program. 
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Accounts Screen 
This is the 'top-level' Home screen which lists the accounts in the 
selected Group, along with their current balance, selectable details, 
the net worth for the Group and your overall total for all groups. 

The middle column can display various account settings such as 
Interest Rate, Balance Limit or Reference. You can tap the column title 
to cycle through them. (If you select "All", it will look through the 
settings in the order : Ref, Limit, Interest and display the first non-
blank entry. (To force a blank just put 2 spaces in the Reference field).  

Use the dropdown selector at top right of the screen to Switch Groups.  

The New button is for creating new Accounts. 

The Edit button allows you to Add/Edit/Delete extra groups, to 
Edit/Delete/Move accounts and to set a Password. 

The View button is for switching between screens and Modules. 

Under the Tools button you can set your preferences, use a Notepad 
facility to record any information about the Group of accounts, the 
Account Info to record account numbers, bank codes, card numbers or 
other details for each account, a Look Ahead option and Backup and 
Restore options (described later) 

The Home button (top left) is actually redundant in this screen as you are already on the ‘Home’ screen, but 
is there for consistency.  On all the other screens it will bring you back to this screen. 

Swiping up and down will change the selected entry, unless you have more than a screen of accounts, in 
which case it will scroll the whole screen.  Swiping to the left will move to the Transaction screen for the 
selected Account. 

Add Accounts 

In the Accounts screen tap New to add accounts, and enter their details: 

 a Name for the account 

 any Reference details 

 whether the balance of the account should be Included in the 
Group total (included accounts are shown with '>' in the first 
column 

 the opening Initial Balance, and whether it is in credit or debit 

 any balance Limit, either a minimum credit for a checking 
(current) account, or a maximum debit for a credit card type 
account 

 the Interest rate applicable, for use by the Automated 
Payments interest transactions 

 the Archive File to be associated with the account (these 
must be created beforehand so if this is the first time leave it 
as <None> and update at a later time) 

 Whether you want a Currency symbol displayed (As stated 
previously I use a dummy account to track Air Miles so this 
option is set to OFF). 
 

Use the Edit button options to Edit or Delete accounts, or to Move them in the list, plus a Password option 
and Create/Edit/Delete Groups (covered later). 
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Password 

The Edit > Password menu option allows you to set a password for 
opening the program.  However, be warned.  Because this program is 
written in JavaScript it is relatively easy to go through the code and 
figure out the encryption method I have used. So this password option 
really only deters the casual user. 

 

 

 

The View button pulls up a menu that is common across all the 
screens, allowing you to switch between the five screens and the five 
Modules. 

 
 
 
 
 
 
 
 
 
 
 
 
 

The Tools button pulls up a menu allowing you to change the Settings, access the Notepad, Account Info, 
Look Ahead and Backup/Restore.  These are covered in more detail next. 

Settings 

There are 4 configurable options for the Accounts Screen: 

 Date format can be set to the 2 international systems. 
 

 Negative display Negative numbers can be displayed in Red, 
in brackets of just as a negative number. 
 

 Middle column can display either the Reference field, the 
Account Balance Limit or the Interest Rate. If you select <All> 
then it will work through all three, displaying the first non-blank 
entry. 
 

 Bottom bar can switch between the Buttons (as shown) or a 
strip of graphical icons. 
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Group Notes 

All of the screens give access to a Notepad where you can add any 
notes you which to keep about that specific accounts Group. 

 
 
 
 
 
 
 

Account Info 

This option shows you any extra 
information you need to store for 
an Account. 

 
 
 
 
 
 
 
 
 
 
 

Look Ahead 

The option allows you to see what the state of your accounts will be at 
a specified date in the future, after all Automated Payments have been 
carried out. 

 
 

Backup/Restore 

Unfortunately, for security reasons, modern smartphone Operating 
Systems limit any interaction to the outside world, so making normal 
backups off-device is almost impossible. The workaround is this 
Backup and Restore system. If you select Backup the program will 
convert all your data to a text file and send it to you as an E-Mail for 
storage elsewhere. Alternatively you can simply Save the E-Mail in the 
Mail app Drafts folder. 

If you wish to subsequently Restore the data then you can open the E-
Mail on the device, do a Select All and Copy, and then follow the 
instructions on the screen and paste the text into the box shown. 
Tapping OK will then replace the existing data with the saved version. 

Note: There are 2 options here to Backup/Restore the main Account 
database and to Backup/Restore the Modules. iOS limitations 
precluded them being combined. 
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Create Accounts Groups 

You can have just one Group for all your accounts, or create multiple 
Groups for normal accounts, savings accounts, business accounts, 
foreign accounts etc. 

All accounts in a Group must be run under the same currency, so if you 
operate in more than one currency you will need multiple Groups. Each 
Group of accounts can access a common set of Categories or use 
different Category files and be linked to a specific Planner Group. 

 tap Edit > Groups > Add group and specify a name for the group, 
select the currency to operate in, the number of decimal places to 
display and set the related group of Categories and a Planner 
Group. (These must be created beforehand).  You also have the 
option of including the total for the Group in the overall Total. 

 tap Edit > Groups > Edit group to change the name or 
currency of operation, or associated Categories for a group. 

 tap Edit > Groups > Delete group to completely remove a 
group of accounts and associated transactions. 

Register program 

Initially, there will be a Tools > Register program to enter your personal registration code to allow full use 
of the program without data restrictions. 
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Transactions Screen 
This screen shows all the current transactions made in the selected 
Account.  The initial balance is shown bottom left and current balance is 
shown at the bottom right.  If there are reconciled entries, as shown in 
Magenta in this screenshot then the bottom left window switches to 
show the Reconciled balance. 

As with the previous screen the middle column can show various 
settings for the transactions, including Category, Reference, Foreign 
cost, or the other account name if it was a transferred transaction or 
<All> as before. Set the middle column with Tools > Settings > Middle 
column, or tap the column title to select an alternative type.  Note:  For 
phones this will be truncated to 4-5 characters because of screen width 
limitations. 

The screenshot also demonstrates the @ symbol (and Magenta colour) 
used to show a reconciled transaction and also shows an estimated 
entry (± and Green) and a deferred transaction which will take place in 
the future (Ð and Blue). 

The top-right drop down menu allows you to switch Groups or Accounts. 

And we also have an extra R button on the bottom row to quickly 
reconcile/unreconcile a transaction. 

Add Transactions 

In the Transaction screen tap the New button to add transactions to the 
account, and enter their details: 

 Select the Date (On an iPhone/iPad there is ‘Date Picker’ 
button to use the built in version.) 

 Add a Description 

 Add a Reference (for use in the middle column) 

 Enter the Amount as a Credit or Debit  

 Select a Budget Category from those you have pre-defined. 

 Select an Attribute if required (see next section) 

Advanced settings 

If required, tap the Advanced menu and this enables you to: 

 Use a different Currency from the primary Group currency if 
you are travelling. 

 Select a Counter if you wish to link this transaction with a 
Counter you have defined earlier. 

 Select another Group and Account to transfer to. 
Transactions can transfer details to another account (even in 
another Group), e.g. to pay a credit card bill with a 
check/cheque. A reciprocal entry will be made in the 'To' 
account. 

 If this is a Vehicle related transaction for purchase of 
petrol/diesel/gas then select the vehicle. 

 If you want this purchase to be included in a House listing 
then select the House. 

 If you want a Planner updated then select a planning agency. 
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Attributes 

If you wish each transaction can be allocated an attribute to show more information: 

 None                 Self explanatory 

 Reconciled (®)    Used when an entry has been reconciled from a Bank statement or some other 
source.  Note: This is an important attribute so it gets its own toggle button in the 
middle of the bottom row of buttons. 

 Estimated (±)      Exact value not known at time of entry  

 Warning (!)         A user-defined flag that can be used to indicate anything. 

 Deferred (Ð)        A transaction that will occur in the future. 

Edit Menu options 
The Edit Menu offers the following options 

 Using a pre-defined template from the Default transactions (see later). 

 An option to Clear all attributes in an account. 

 Use the Last transaction entered as a template. 

 Move or Copy a transaction to another Group/Account. 

 Edit a transaction. 

 Delete a transaction. 

 Archive transactions. 

Move/Copy transactions 
Use this option of you have accidently put the transaction in the wrong 
account.  Once you press OK, the transaction will be recreated in the 
new Group/Account and you will be given the option of deleting the 
original entry. 

So to ‘Move’ a transaction delete the original and to ‘Copy’ a transaction 
do not delete the original. 

Edit Transactions 
Simply use the Edit > Edit transaction menu option to amend an entry. 

Delete Transactions 
Simply use the Edit > Delete transaction menu option to permanently remove an entry. 

Archive or Remove Transactions 

When you receive a bank or credit card statement, the recommended procedure is to check the entries in 
the account and reconcile each by tapping the R button to mark with ® symbol. The Balance figure at the 
bottom of the screen will change to show the running reconciled total, which should match the running 
balance on your statement. 

An option in Tools > Settings can be turned on for Auto-step on reconcile. The highlight will then 
automatically move down to the next unreconciled entry after one is reconciled. 

When entries have been checked use Edit > Archive transactions to archive the reconciled transactions 
from the live account to make room for new transactions, and to store them for reference in an Archive file 
(these must be created beforehand). 

Note that, if required, the Archive entries dialog gives the additional flexibility of: 
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 Archiving or Removing (deleting) the entries 

 Acting on only the Reconciled Entries, or All entries 

 Updating the Balance of the Account to reflect the removal of 
the transactions 

 Specifying the Archive file to be used (it will default to the 
one selected in the Account settings) 

 Specifying the Start and End dates (From and To). 

 
The Tools button pulls up a menu allowing you to change the Settings, 
access the Notepad, Set up Default Transaction, Counters and Colours 
and Filter the display. These are now covered in more detail. 
 

Transaction Settings 
This is where you can change the default settings for Transactions: 

 Auto-Step on Reconcile  If this is set then when you reconcile 
an entry the selection will jump to the next unreconciled entry.  
Saves having to keep moving the selection if you are reconciling 
a whole month with a statement.  Note:  This is a Global setting 
for the whole program. 

 Auto-defer entries  If this is set then any entry later then 
today’s date will have the deferred attribute set automatically.  
Note:  This setting is Account-specific. 

 Include deferred entries  If this is checked then the value of 
deferred entries is also included in all the balance displays. 
Note:  This setting is also Account-specific. 

 Middle Column  Select the information to be displayed in the 
middle column.  This can also be changed by tapping on the 
column header.  Note:  This setting is also Account-specific. 

 

Setup Default Transactions 

If you have a transaction you enter regularly that has the same settings, 
such as an Electricity Bill that always pays the same company and 
updates a Category, and the only difference is the amount, then it is best 
setup as a Default Transaction for use as a template. 

Use the Tools > Setup defaults > Add default menu option and fill in 
all the details as for a normal transaction, but using a name instead of 
the date.  Any detail that you don’t know and will fill in later just leave 
blank. The menu also contains Edit and Delete options for the Default 
Transactions. 

Note that the Default Transactions are specific to the Group in which they were created. 

Setup Counters 
If you use a cheque/check book with numbers, or any other system 
associated with a number, you can define a counter, giving it a name 
and start number. Then when you add a transaction and link it to the 
Counter, the number will be added to the Reference field and 
automatically incremented for the next entry.  The best way to utilise this 
is to create a Default Transaction called “Cheque” (or “Check”) and link 
it to the Counter.  Then each time you use the book, select the top 
dropdown menu in the Edit menu and select the Default. 
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Setup Colours 

Each of the attributes can be allocated a different colour and this option 
allows you to specify your preference. 

 
 
 
 
 

Filter Transactions 

The entries in both the Transactions and Archive screens can be filtered 
to show only those that meet your selected criteria. 

Tap Tools > Filter and enter any combination of criteria: 

 Category 

 Text string 

 From and To Date range 

A coloured 'Filtered' bar at the bottom of the screen indicates that a filter 
is applied. Tapping it will clear the filter. 

Note: The text searches both the Description field and the Reference 
field, and at the moment if you select a Category and a Text string then 
BOTH have to be present for the transaction to be displayed. 
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Budget Categories Screen 
This screen allows you to keep track of how much you are spending (or 
receiving) for various budget expenses (Oil, Gas, Rent, Holiday, Food, 
Car, Salary etc.) by allocating transactions to categories. Totals of the 
Spend and Income amounts are shown at the bottom of the screen. 

You can create multiple Category Groups using the Edit menu > 
Budget groups options. Then associate the group with a specific 
Group of accounts from Add or Edit group in the Accounts screen. 

Switch Budget groups using the dropdown selector at top right of the 
screen. 

When entering a transaction into an account, select one of the 
categories in the Category field. The value of the credit or debit will be 
automatically added to the Spend figure for the category, and the % 
complete calculated. If the transaction in an Account is later deleted or 
updated, the Category value will be adjusted accordingly. 

At the end of an accounting period, use Edit > Reset categories to 
start again. 

Add and Edit Categories 

Tap New to add categories in the Category screen: 

 specify a Name for the category 

 enter an Estimate of the total amount likely to be 
spent/received, and whether it is a Spend or Income (debit 

or credit). 

The usual options are available through the Edit menu to Edit, Delete, 

and Move the categories. 

When updating a category you have the ability to: 

 change the Name 

 change the Estimate to a new credit or debit amount 

 change the Spend / Income value by either a credit or debit 
amount, or to give it a new absolute value. 

Reset Categories 

Once a Budget cycle is complete (I tend to use an annual cycle) you will 
need to reset all the categories. To do this tap on the Edit > Reset 
Categories menu option. You will then be given the option to: 

 Reset just the Selected category or All categories 

 Set the Estimate value to the Current spend (i.e. last year's 
spend becomes next year's budget estimate), or to Zero it, or 
to leave it at the current amount. 

 Reset the Spend/Income amount to zero, or leave it alone. 

Add and Edit Budget Groups 

Tap Edit > Budget Groups to add a new Budget group.  Specify: 

 Name 

 Currency to be used 

This option also allows the Editing and deletion of the Groups. 
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Budget View menu 

The entries in the View menu are the standard ones allowing access to the other screens and modules. 

Budget Tools menu 

The Tools button pulls up a menu allowing you to access the Notepad. There are no user-selectable 
settings for the Budget Categories. 
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AutoPayments Screen 
This screen shows details of your Automated Payments (AKA Standing 
Orders, Future Transactions, Scheduled Transactions or Direct Debits) 
and Interest payments made to or from accounts. 

Each Accounts Group has its own related AutoPayment screen. 

Dates for actioning payments can be for any multiple of daily, weekly, 
monthly or annual periods. The screen will show the payments in due 
date order. 

Note that when an order has completed the requisite number of times, 
the date will change to 'Completed' in case you wish to reset it. 

Use Edit > Action now to 'force' an order to transact ahead of its due 
date. 

 

 

 

 

Add Payment 

Tap New button to create a payment: 

 Set the initial Date you first wish it to be actioned 

 Add a Description 

 Enter the Amount to pay, and define whether it is Fixed 
(same every occurrence) or Variable (you will be asked for 
the amount when it actions) 

 Specify the From Account or To Account (or both for a 
transfer between accounts) 

 Select the Period as Daily, Weekly, Monthly, or Annually 

 Set the Interval for how often the period should occur. 
Therefore, for a quarterly order submit a period of 'month' and 
an interval of 3. 

If required tap the Advanced menu to define: 

 The text to appear in the Reference field 

 A Budget Category that will be assigned to the entry 

 If you want a Planner entry updated then select an agency 

 An Attribute to automatically apply (Reconciled, Estimated, 
Deferred, or Warning) 

 Number of times the payment is to be carried out, or 
Forever 

The Edit menu has the usual options to Edit or Delete payments. 
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Add Interest Payments 

In the AutoPayments screen use Edit > Add interest payment to 
create a specialized type of payment to make estimated interest 
payments to or from accounts: 

 Set the first Date for actioning 

 If needed change the Description, the default shows it is 
estimated 

 Select the Account 

 Select the Period as Daily, Weekly, Monthly, or Annually 

 Set the Interval for how often the period should occur 

When the Interest order actions, the actual amount credited or debited 
to an account will simply be based on the interest rates set for the 
account and its balance at the time. 

AutoPayments View menu 

The entries in the View menu are the standard ones for switching to other screens. 

AutoPayments Settings 

There are no user-selectable settings for the Budget Categories. The Tools button pulls up a menu allowing 
you to access the Group Notepad. 
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Archive Screen 
This screen allows you to look at transactions previously archived from 
Accounts. It is similar to the Transactions screen the only difference 
being that you cannot edit the entries. 

Because Archive databases can get quite large, they are displayed in 
manageable blocks that can be scrolled through (the size of the block 
defaults to 50 but can be changed if required). The entry numbers are 
displayed at the bottom along with Start/Prev/Next/End buttons for 
moving through blocks. 

Tap New to create new archive files. How you use the archives is up to 
you. You can have just one shared archive for all accounts, or an 
unlimited number, or one for each of your accounts. 

Tap the Edit button for menu options that allow the Archive files to be 
Edited (renamed) or Deleted. 

Archive View menu 

The entries in the View menu are the standard ones for switching to 

other screens. 

Archive Tools menu 

The Tools button shows options to: 

 Set the Preferences 

 Access the Notepad 

 Filter the display 

 Export the archive. 

 

Archive Settings 
The user-definable settings are: 

 Middle column  Select the information to be displayed in the 
middle column. This can also be changed by tapping on the 
column header.  Note: This setting is global 

 Grid size  Select the size of the blocks to be displayed. 

 

Filter Display 

This performs the same function as the Filter in the Transactions 
screen with the added extra of a Value field. 

 

Export 

Use this to send the archive as an E-Mail to yourself (or others) in the 
standard CSV format that can then be loaded into Excel or any other 
spreadsheet program. 
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Currencies Screen 
Each Group in the program can be run in a different currency, assigned 
in Accounts screen Edit > Groups > Add group. In addition the 
program allows you to input transactions in other currencies for 
temporary use e.g. while on holiday. The costs will be converted to your 
primary currency at the rates you define. 

Three main currencies are pre-defined. You can set more up in the 
Currencies screen. The screen lists the countries with the symbol and 
exchange rate. 

The New button allows you to define the currencies you will use. 

To update a currency use Edit > Edit Currency. 

 Select the Country, and change the rate to the current 
exchange rate. 

To delete a currency select the Country then use Edit > Delete 
Currency. 
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Fuel Module 
The Fuel Module allows you to track the fuel consumption of up to 10 vehicles. It maintains a record of the 
Amount Paid, Price per Gallon/Litre, Distance covered and the Fuel Consumption. The program is fully 
configurable for all international measures, allowing entry and/or display in miles/kilometers and 
litres/gallons(UK or US). For each vehicle there are 3 screens: 

Fuel screen 
 The main screen for entering the current details and viewing historical values of fuel purchases 

and consumption. 

Reminder screen 
 for entering date and distance alarms. 

Expenses screen 
 for recording other running costs. 

Fuel Screen 
The Fuel screen is where you see the details of new fuel purchases and 
shows a cumulative record of all past entries with consumption rates. 
Two consumption values are shown; the spot consumption since the 
last fill and the running average consumption. 

You can tailor the screen display to your requirements. Tapping on the 
column heading titles allows you to cycle round to select which of the 
recorded details are shown. 

 the second column can show – cost, price, or amount of fuel 

 the fourth and fifth columns will show the consumption rates 
(spot and running average respectively) in any of the 8 units 
available when setting up vehicles. 

The bottom line gives the total cost and total quantity used.  

Use the drop down menu top right to switch vehicles if you have more 
than one. 

Vehicles 
You can maintain records for multiple vehicles. 

 Tap Edit > Vehicles > Add Vehicle to create vehicle files. 
Enter the name, starting odometer reading and currency. 

  Tap Edit > Vehicles > Edit Vehicle to amend any of the 
vehicle details. 

 Tap Edit > Vehicles >  Delete Vehicle to remove vehicle 
files if you no longer have the vehicle or need to keep 
records. 

The vehicle screen is also where you define the various units you want 
to use for Volume of fuel, Distance travelled, and fuel Consumption. 

Calculation Logic 
To ensure the consumption calculation is correct, each entry must be 
taken at a point where the quantity of fuel is identical.  The easiest way 
to do this is to record the details each time a fuel tank is filled up.  Then, 
the next time the tank is filled you know how much fuel you have had to 
put in to replace the fuel used since the last time, and the distance you 
have covered.  From this an accurate consumption figure can be obtained. 

Note that the first entry is just a baseline entry, so although you enter details such as amount/cost etc, it is 
actually only the absolute distance figure that is used. And with only one entry, obviously no consumption 
figures are available.  Next time you fill the tank and enter the details, the consumption figures will appear. 
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Add Fuel Purchases 
So, each time you fill your vehicle with fuel, select the New button and 
enter details of your fuel purchase: 

 Date 

 Cost 

 Quantity of fuel added 

 The Distance reading from the odometer 

 Confirmation that you have a Fulltank. 

If you have not filled the tank, simply uncheck this option and 
the fuel consumption will not be evaluated for that entry (will 
show as ---- in the screen display). 

However, the better method for adding fuel purchases is to make them as a transaction in an Account 
(typically when you pay by credit card). Specify a link to a Vehicle in the Transaction entry Advanced 
settings screen, then after entering the Transaction details you will be automatically presented with this Add 
Fuel dialog with the Date and Cost already filled in. After filling in the Quantity and the present Distance 
and tapping OK the entry will be added and a pop-up display will tell you the spot consumption since the last 
entry. 

The Edit button gives you access to the usual Edit and Delete options. 

The View button gives the standard menu, but with an extra Module 
screens option.  This opens a secondary menu appears with 4 extra 
options: 

 Graph:   To show the consumption in a graphical format 

 Statistics:  Some useful facts about your usage 

 Remind:     Accesses the Reminder screen. 

 Expenses:  Accesses the Expenses screen. 

Graph 
This shows the consumption in a graphical format 

Statistics 

This screen shows some useful pieces of information about your 
expenses and running costs. The screenshot shows them for 2013, by 

tapping on the year you can select other years from a dropdown menu. 



 RMRAccounts  Personal Accounts Suite 

www.rmrsoft.com page 22 

Reminder Screen 

The Reminder screen is where you set warnings which can be used to 
alert you when servicing is due, or insurance needs to be renewed. 

Reminders can be based on Date or Distance (or both). The program 
will then inform you when the date or distance of a fuel entry triggers 
the reminders. 

 

 

 

 

 

 

 

Add reminders 

Use the New button and enter the details for each reminder: 

 Turn on the Date trigger and specify a Date, 
and/or 

 Turn on the Distance trigger and specify a Distance in Miles 
or Kilometres 

 Reason – add a description, or the Select option provides a 
dropdown set of frequently used reasons to save you typing 
them in. 

The Reminders screen Edit button allows you to Edit or Update 
reminders. 

The Reminders Tools button has a Settings option to specify how 
many days before an event you wish to be notified by an Alarm. 
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Expenses Screen 

Use the Expenses screen to keep a record of additional running costs 
for each of your vehicles, for example insurance, maintenance, parking, 
etc. The running total is shown at the bottom. 

 

 

 

 

 

 

 

 

 

Add Expense entry 

Use the New button to add an Expense, specifying Date, Reason, 
Cost, and Distance. 

As usual the Edit button allows you to Edit and Delete entries. 

 

 

 

 

 

The Tools button in the main fuel screen gives the following options: 

 Settings 

 Vehicle Notes:  This is the same as the main screens but in 
this case the Notepad is just for the Vehicle. 

 

 

 

 

Fuel Preferences 

The following settings are available: 

 Decimal places to show for each of the columns 

 The Second column entry. As usual this can also be toggled 
by tapping on the column header. 

 Whether the default setting for entry should be a Full tank. 
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Home Module 
The Home Module allows you to track the contents of multiple houses for insurance purposes.  Each Item is 
allocated to a Room and a Category and given a value and designated if you wish to have it replaced on a 
‘New for Old’ basis or just the Current Value.  Each year you can uprate the value of the Items by a 
percentage to take account of inflation. 

For each House there are 3 screens: 

Items screen 
 For displaying the details for each Item. 

Rooms screen 
 For displaying the contents of each room and the overall room value. 

Categories screen 
 For displaying all the Items allocated to a specific category and the total value. 

 

Houses 

You can maintain records for multiple houses. 

 Tap Edit > Houses > Add House to create house files. 
Simply enter the name and the currency you wish to use. 

 Tap Edit >Houses > Edit House to amend any of the details.  

 Tap Edit > Houses > Delete house to remove house files if 
you no longer need to keep records. 

 

 

 

 

 

 

 

Items Screen 

The Items screen is where you see the details of the Items.  At the 
bottom of the screen is a display of the total number of items in the 
database and the total value of all the items. 

You can filter the display to show All Rooms or All Categories, or just 
the items from specific rooms and categories, using the drop down 
selectors. 

You can select between multiple houses using the drop down selector 
at top right of the screen. 
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Adding Items 

Tap the New button to add an item and enter the details for: 

 Date 

 Description 

 A Reference (if required) 

 Value 

 Whether you wish it to be ‘New for Old’ 

 Location where the item is kept 

 Category 

The View button gives the standard menu, but with an extra Module 
screens option.  If this is tapped a secondary menu appears with two 
extra options: 

 Rooms:   To show the contents of a Room. 

 Categories:  To show all the Items associated with a Category. 

 The Tools button offers the following: 

 Settings to specify what you wish the ‘New for Old’ setting to 
default to for Item entry, and a screen sort option 

 House Notes:  The standard Notepad, this time for each House. 

 Uplift Value:  Increase (or decrease) the value of all the Items by 
a fixed percentage.  
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Planner Module 
The Planner Module allows you to track the day-to-day expenses associated with running a house. You can 
define payment schedules for each Agency, allowing you to carry out a comprehensive annual budget. 

Planner Screen 

The screen lists the various agencies with a six-month matrix of the 
predicted costs.  You can reconcile entries, turning them red, by 
selecting them and tapping the ‘R’ buttons at the bottom. 

On initial opening the screen defaults to have the current month in the 
second column so you can instantly see if the previous month’s entries 
have all been reconciled.  Swiping the screen will show the other 
months. 

The entries can also be linked to specific Transactions or Default 
Transactions so they are reconciled automatically without having to 
visit the screen. And the predicted values are updated to the actual 
values so the accuracy of the Budget improves with time. 

As usual you can define multiple Planners and these are selected from 
the drop down selector top right. 

 

 

 

Use the New button to add Agencies. Then use Edit > Update cost 
estimate to enter a Value amount for a particular Month when a 
payment is made, or for All months. 

The Edit menu also has options to Move, Edit (rename) or Delete 
agencies. 

The View button acts as normal. 

The Tools button offers the following: 

 Plan Notes  The standard Notepad, this time for each Planner 
file. 
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Invest Module 
The Invest Module allows you to track the day-to-day valuation of a 
simple portfolio of investments.  It does not replace a proper Investment 
application but still allows you to track your Total Worth. There are two 
screens: 

Main Screen 

This displays the details of the investments and allows the usual 
Adding, Editing and Moving of the entries Note:  the Edit investment 
option is to change just the Name and Number of units held. There is a 
separate Update value option for the regular updates with Date and 
new Value. 

This screen is intended as a ‘snapshot’ of the overall value of the 
portfolio and it can be included in the ‘Total Worth’ value on the main 
Accounts screen. 

The Tools > Settings allows you to specify: 

 Decimal places to be used 
for the Number and Value 
columns. 

 Whether the total value of 
the investments should be 
Included in Total Worth 
display of the Main Accounts 
screen. 

 Whether to display the date 
column in the Main screen 
to show when the last update 
was carried out. 

History Screen 

For each investment you can display a History of the performance of 
the investment value over time. Each time you do an Update Value in 
the Main screen a new entry is added to the History screen. (Note, you 
can have only one entry per day so if you use Update Value twice in a 
day only one entry is added to the History screen). 

 

 

 

From either of these screens you can 
select View > Module screens > 
Graph to show a graphical view of 
the performance. 

 

 

 

 

 

In the History screen, the Tools menu allows you to Reset the Start 
Date of the database in case it has got too long. 
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Utilities Module 
The Utilities Module allows you to track the day-to-day usage of the various utilities.  I use it to track 
Electricity (in case I need to send a meter reading when I do not have access to the meter), Internet 
Broadband (to ensure I do not exceed my monthly cap), Heating Oil (to make sure I order a fill in good time) 
and Water. 

The Main screen simply shows the details of the readings (with an 
optional Remarks column) for each utility. 

Use Edit > Utilities to Add, Edit or Delete Utilities and as usual select 
the required utility from the drop down selector at top right. 

Then use the New button to add entries with their Date, Value reading, 
and any Remarks. Use Edit > Edit and Delete as usual. 

 

The bottom line shows a Predicted value for a given date. Set this 
Prediction date in the Tools > Settings menu. 

  

 

 

 

 

The Tools button also offers an option to Reset the start date if required. 
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Checklist Module 
 The Checklist Module allows you to track lists, either simple or ToDo lists 

The Main Screen shows the lists and the one here demonstrates some 
of the functions available.   Each entry can have an attribute of 
“Completed” or “Title Entry” as shown. 

The last column can actually display one of 2 separate values, the 
primary “Extra” detail is shown initially and the secondary one can be 
displayed by tapping on the title of the column. 

An entry can be marked a Completed by tapping on the ‘R’ button on 
the bottom row. 

As usual you can switch between Checklists using the drop-down menu 
on the top right of the screen.  

Finally the words “Remaining” and “All” can be tapped to display ether 
All the entries or just the uncompleted ones.  The current display is 
highlighted in magenta in this case (The same colour you defined for 
reconciled in the Transaction screen).   

 

Tap the New button to add an item 
and as usual enter the details for: 

 Description 

 The 2 Extra details 

 Attribute 

 

 

 

 

The  Edit button gives access to the Checklist Group options, clear all 
the Completed flags and the usual Edit/Move/Delete options. 

 

And finally the Checklist Group 
options allow you to Add/Edit/Delete 
Checklists, where you give the 
Checklist a Name and define the titles 
of the 2 Extra fields.    


