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RMRData: Quickstart 
 

RMRDATA is a database program designed to hold records of all your financial accounts, pin 
numbers, logins, passwords, and other personal information in a secure fashion. The basic idea 
is that you create Entries and group them together under various Types (Bank Accounts, 
Credit Cards, Passport Details etc). Then you can view the Details in three different ways: 

 
• Directly on screen, where the Types, Entries and Details are shown in 3 columns. As you 

cursor the highlight down the Entries column, the appropriate Details can be viewed on 
the right. Counters for the index of the highlighted Type / total number of Types, and 
index of Entry / total number of Entries for that type are shown at the bottom of the 
screen. 

 

The example above also demonstrates that a Memo has been added to the “My Card” 
entry (marked with ‡), which can be viewed using the Memo CBA button on the right. The 
titlebar indicates that this database is encrypted (see the Passwords section for more 
details). 

 
• A second method of viewing the details is through the Details Ctrl+G option in the View 

menu. The screenshot below shows how the details are presented on a scrolling screen 
in the centre of the screen. 
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• The third method is with the Card view Ctrl+O where selected details are shown as though 

on a credit or membership card. See the Using Cards section for more details on how to 
design and name different card formats and how to link them to each Type. 

 

In this view the CBA buttons now serve a different purpose. You can quickly cycle through 
the card entries for the selected type using the Prev and Next buttons (the Left/Right 
arrows also have the same effect) and you can expose the PIN number of the card using 
the Show Pin button. 

Moving around 
Use: 

• Left/Right arrow to move between columns. The column header of the selected column 
will be in inverse video. 

• Left/Right arrow to move between cards in the Card view. 
• Up/Down arrow to select types or entries or to scroll though the details. 
• PgUp/PgDn to move a screenful at a time (Ctrl+Up/Down arrow on 9300/9500). 
• Home/End to go to the top or bottom entry in the display (Ctrl+L/R arrow on 9300/9500). 
• Tab/Shift+Tab to move between columns (configurable in General preferences). 
• Shift+Ctrl+O or Open menu option to switch between databases (if you have more than 

one). 

Note: The joystick/navigation button can also be used instead of the arrow keys.  
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Using Databases 
The File menu gives the options for maintaining a number of different databases: 

• Use Create database, Shift+Ctrl+N, to build a new database with a number of pre-
defined types and a couple of example entries that can be amended or deleted. The 
given name for the database will be shown in the titlebar. 

• Open database Shift+Ctrl+O, switches between databases (this option will be greyed out 
if you have only one database). 

• Use More > Delete database to delete a database if no longer required. (Note that you 
cannot delete the current database so if you wish to do that you must switch to another 
database). 

• Use More > Rename database to change the name of the current database. 

See the Security section for how to use the Password option Ctrl+Q. There are also options to 
Import and Export databases and to Backup and Restore databases. These are covered in 
specific sections later in the manual. 

The Add to Desk option is primarily for users of the 9210/9290 Communicator and is not 
implemented in the 9300/9500. If you wish to add a shortcut to the Desk for these phones, 
simply highlight the Icon in its existing folder and use the Show in Group Shift+Ctrl+S option to 
select the Desktop. 

Security 
For each of your databases you can apply three different levels of security: 

1. Insecure (the default when you started). No security is applied, and the program can be 
freely opened. 

2. Password controlled only. This stops casual viewing of the data, although it is still 
stored on the Communicator disc in a format that could be viewed with a text editor. 

Use the File > Password Ctrl+Q option to protect individual databases as required. 

• Turn the Password set to On. 
• Enter the character string in the New password field and repeat it in the Confirm 

password field. 

Note: Passwords are case sensitive. 

You can decide how frequently the Password dialog is shown and you are asked to enter 
the code, with the appropriate options in General preferences > Password CBA button. 
These can be turned on/off when Starting the program, Switching databases, Switching 
to the program, and Opening the phone. 

To remove a password use the Password option Ctrl+Q again: 

• Enter the current Password to gain access. 
• Leave Password set to Off. 
• Leave the New password field and Confirm fields blank. 

3. Encrypted. This is the most secure level. The data is scrambled as it is stored on disc, 
using an encryption algorithm based on the Password. This makes it impossible to read 
the data. Use Tools > Encrypted Shift+Ctrl+X to set or clear the encryption. Because the 
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password is used to encrypt the data you will not be allowed to encrypt any database 
without a password being set first. 

Note: If you forget the password for an unencrypted database we can probably recover the 
data. However, if you forget the password on an encrypted database you will NEVER be able to 
recover the data, so make sure you use something memorable. 

Backup/Restore 
Under the File > More menu there are Backup database and Restore database options. 

Backup database Shift+Ctrl+B allows you to manually keep a copy of your data elsewhere on 
the system for security. The set of backed up data files is stored in the: 
Communicator:\My Files\RMR\Backups\RMRData\  folder on the 9300/9500, or 
Communicator:\System\Apps\RMRData\Backup\  on 9210/9290. 

Use the Backup options from the CBA button in General preferences to enable regular 
automatic backups of your data, or to change the location of the backed up files. 

If necessary use Restore data Shift+Ctrl+R to restore all datafiles in the case of data loss. 

Note: All current data in the program will be overwritten by restoring the backed up data. 

Other Functions 
The program also has other useful functions such as Zoom, Find entries, Move entries, and 
Export/Import in CSV, Tab-delimited and a text format similar to that used by Handy Safe. Most 
of these are covered later in the Manual. 
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Using Types 
Types are the top level categorization in a database for information of the same type (Bank 
Accounts, Credit Cards, Passport Details etc), and are listed in the first screen column. The 
default database gives you several pre-set entries as an example, but you can delete or amend 
these, or create different ones to suit your needs. A counter at bottom right of the screen 
indicates the number of the highlighted type, and the total number of types in the database. 

The options in the Types menu (visible only with the highlight in the Types column) allow you to 
modify the types: 

• Use Add Ctrl+N to create a new Type. In the first dialog enter a Name and specify which, 
if any, Card display format you wish to use. Then use the Fields CBA button to define 
the titles to be used for the individual details fields. 

• Use Update Ctrl+V to modify an existing Type. This is similar to Add, allowing you to 
change the Name, the associated Card format and the Field titles. 

• Use Delete Ctrl+W to remove any unwanted types. Note that you can only do this if there 
are no associated entries. 

• Use Move Ctrl+H to rearrange the order of the types listed in the display. 
• There are also options to Import and Export Types. These are covered under specific 

sections later in the manual. 

Using Entries 
Entries are your individual records with your details filed under the Type categories. The default 
database gives you a few example entries to show the principle, listed in the second screen 
column as you scroll down the Types. A counter at bottom right of the screen indicates the 
number of the highlighted entry, and the total number of entries in that Type. 

The options in the Entries menu (the full set of options are only visible when the highlight is in 
the Entries column) allow you to modify the types: 

• Use Add Ctrl+A, or the Add entry CBA button to create a new Entry. In the first dialog 
enter a Name and specify which Type it belongs to. The CBA Button marked Memo 
allows you to add a note for the entry. Then use the Details CBA button to enter the 
information for each of the specified fields. Note that the fields accept free-format text so 
you can enter dates or numbers as text for complete flexibility. 

While in this dialog, the CBA Button marked Colour allows you to specify the Background 
of the Card display. Use the Up/Down Arrows (or joystick) to select the colour and the 
Left/Right Arrows (or joystick) to adjust the ‘hue’. Shift+Left/Right Arrows jumps the 
slider by a larger amount and Ctrl+Left/Right Arrows gives 100% or zero. Alternatively 
use 0-F to use a pre-defined colour. 

• Use Update Ctrl+U to change an existing Entry. This is basically the same as Add above, 
allowing you to change the name, the type, the background colour of the card and the 
information. 

• Use Delete Ctrl+D to remove any unwanted entries. 
• Use Duplicate Ctrl+B to create an identical card for subsequent editing. 
• Use Move Ctrl+J to rearrange the order of the entry listing in the display. 
• Use Sort Ctrl+L to sort the entries alphabetically. 
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Using Cards 
The Card format view shows the details for an Entry in a ‘real world’ way as though on a credit 
or business type card (see screenshot in the Overview). View the card with View > Card menu 
option, Ctrl+O, the spacebar or enter key (configurable in General preferences), or the Card 
CBA button. All Types of Entries can have a card view chosen from a small library of card 
display formats, or you have the option of designing your own card. 

The options in the Cards menu allow you to design your own cards for use in the Card display: 

• Use Add Shift+Ctrl+J to create a new card. In the first dialog specify the Name of the 
card, the Number of lines of text you wish to display on it and what the card Width 
should be. 

Use the Lines CBA button to define which field should be shown on each line of the card, 
allowing you to rearrange the order of the information if necessary. 

Use the Icon CBA button to insert a specific icon on the Card display. (Remember the 
background colour is set in the Add/Update Entry dialogs). 

Note: These are the icons available at the moment. If any user wants to add to the 
selection simply send us the icon for inclusion in the MBM file. The icons need to be 40 x 
40 pixels x 256 colours please. 

• Use Update Shift+Ctrl+L to change an existing card. This is similar to Add above, 
allowing you to change the name, the width, the lines and the icon. 

Note: that because of its complexity, the Credit Card design is fixed and cannot be changed. 

• Use Delete Shift+Ctrl+S to remove any unwanted cards. 

Once a card format has been designed, you can allocate it to a Type using the Type > Update 
menu option. 

Other Functions 

Find 
The Find Ctrl+F menu option allows you to jump quickly to an entry. Simply enter the text 
required and the first entry that contains that text will be displayed. 

Then use Find next Shift+Ctrl+F to continue searching through the entries. 

Import & Export 
There are various Import and Export options, all of which work in TAB-delimited or Comma 
Separated Variable (CSV) format text files. 

1. Import Ctrl+X in the Types menu. Use this to import Types to the database if you want 
to design the Types off-line. To see the import format required, simply perform an export on the 
default types and use that as a template to build your own. 
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2. Export Ctrl+Y in the Types menu. Use this to export the Types so that they can be 
viewed and/or edited in a text editor/word processor (TAB delimited format) and spreadsheet 
program (CSV format). 

3. Import database Shift+Ctrl+I in the File > More menu. Use this to import Entries into the 
database. Again, to see the import format required, simply export the default types and use that 
as a template. 

4. Export database Shift+Ctrl+E in the File > More menu. Use this to export Entries from 
the database to be viewed and/or edited in a text editor/word processor (TAB delimited format) 
and spreadsheet program (CSV format). You can choose to export All entries or just those from 
the Selected type. 

At the request of Steve Litchfield (3-lib) the Database import and export also has an additional 
mode called Text which outputs each field on a separate line. This is based on the export 
format used by Handy Safe, so it should be possible to import databases previously exported 
from this program. Obviously it will not be 100% perfect, as we disagree with some of the field 
titles used by Handy Safe, and also we had to assume the default values and icons in Handy 
Safe as well. So if you have changed any of the defaults then the Entries may be imported 
under a different Type name, but any differences can be very quickly fixed after the entries have 
been imported by using Types > Update and Entries > Update to change the type and/or 
fields. 

Note: you cannot Import to an encrypted database, so you will have to Unencrypt the database, 
then carry out the Import, then Encrypt again. 

Note: Export will produce an unencrypted text copy of the database, so due care should be 
taken. 

The exported files will be stored in the Communicator\My Files\RMR\Exports\ folder on the 
9300/9500 and in the Communicator\My Documents\ folder on the 9210/9290. 

Memopad 
The memopad feature allows you to record any notes about an entry that is not covered by the 
Type headings. 

This memo can be created or viewed by using the View > Edit memo Shift+Ctrl+Z menu 
option, or by using the Memo CBA button, or by tapping the spacebar or Enter key (depending 
on the selection made in the General Preferences). 

An entry that has a Memo attached will be shown by an additional (‡) symbol after the Entry 
name. 

Miscellaneous 
Switch Title Shift+Ctrl+T – allows you to remove the title bar. 

Full Screen Ctrl+T – removes the Information Window and CBA button labels. 

Zoom in/out – change the font size of the display. 

Compact database Shift+Ctrl+C – after deleting a number of entries it is probably a good idea 
to run this option to recover any unused space. 

About RMRData – an information screen with details of the program. 
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Setting RMRDATA preferences 
The program is extremely configurable so you can change many settings to suit your way of 
operating. 

View Preferences 
The View preferences Ctrl+K options allow you to configure: 

• Font type allows Arial or Times Roman. 
• Change the Header window colour, 
• Type column % and Entries column % allow you to adjust the widths of the columns to 

suit the text. 

The CBA button marked Card accesses the colour picker to set the default card colour. 

General Preferences 
The General preferences Shift+Ctrl+K options allow you to specify: 

• the action you want the Enter key to carry out - either display the Details, Memo, or Card 
for the selected Entry, or Add an entry. 

• the action you want the Spacebar to carry out - either display the Card, Details, or Memo 
for the selected Entry. 

• the action you want the Tab key to carry out - either Switch panes or Update an entry. 

The CBA button marked Password allows you to specify when the Password dialog should be 
used to prevent the database from being opened directly for viewing, and can be set when 
starting the program, switching database, switching program, and opening the phone. 

The CBA button marked Backup allows you to specify the automatic backup options: 

• Auto turns on the automatic backup, and sets the frequency to Daily, Weekly or Monthly. 
• Start date when you want the first backup to run. 
• Whether a Prompt is required. 

And the CBA button marked Location can be used to change the location of the Backup files. 
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