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RMRVactrac: Quick start
RMRVactrac, ‘Vacation Manager’ is designed to allow you to keep track of you or your employee’s 
work leave (e.g. vacations, sickness, maternity).

People

Multiple people can be entered. Each person is defined by their first name, last name, department, 
phone number and optional information field. These details can be used for sorting and filtering 
purposes.

Leave

Each person's leave is assigned to a category (e.g. vacation, sickness, maternity). A leave has a 
duration (from, to) that will be used for category accounting calculations. Additionally a leave can 
optionally have a description note.

There are other special kinds of leave (e.g. public or company holidays) that can be entered to apply 
to all people. These have no category assigned and don't have to be used in the accounting.

Category

Each leave category has a text label (e.g. Vacation) and a symbol (e.g. V). You can set a category to 
auto count the leave days, and optionally to count workdays only and to skip the public holidays.

Accounting

Accounting is done on a period basis. A period is a duration of one year, which does not necessarily 
need to start on a calendar year boundary (e.g. fiscal year in some countries, 1-Oct-1997 - 30-Sep-
1998, business year). You enter an initial entitlement value for each period and the program will 
calculate the balance for each category for this period. Balances of a period will be added to the start 
value of the next period if carry forward is switched on.

Date screen display
This screen shows a list of the people and their leave entries for a 4 week-period. The program 
starts up with ‘Today’ roughly in the middle of the period, shown as a shaded bar coloured 
according to the setting in View Preferences.

Non-working (weekend) days are also shown as shaded bars, again using a colour defined by 
the setting in View Preferences.
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Any Public Holidays (when defined) will also be shown as shaded bars, again using a colour 
defined by the setting in View Preferences.

Each leave entry is shown graphically using a colour as defined by the category and a label also 
defined by the category and by the setting in View > Leave label.

The displayed dates can be changed using the cursor keys or the joystick.

All operations on Files, People, Leave, Public Holidays and Categories are carried out through 
the Menu options or appropriate hot-keys. See separate Help topics for each option.

Category screen display
This screen shows a list of the people and summaries of their leave entries for the current 
annual period as show in the Title bar. The program starts up in the current period and shows 
the Leave status for the first 3 categories. The other categories can be seen by scrolling right 
using the cursor keys or the joystick.

The program defaults to a current period of 1 Jan to 31 Dec of the current year. If you wish to 
use a different period change the start date to another day/month (example 1 April) in General 
Preferences.

The CBA buttons can be used to look at the summaries for Next Year or Previous Year.

All operations on Files, People, Leave, Public Holidays and Categories are carried out through 
the Menu options or appropriate hot-keys. See separate Help topics for each option.

Moving around
Use the following keys to move around dates and categories:

• Up/Down arrow keys to select entries.

• Shift Up/Dn (Pg Up/Down) to move a screen at a time.

• Ctrl Up/Down (Home/End) to go to the top or bottom entry in the file.

• Ctrl+Q to Switch view between the Dates screen and the Category screen.

In Dates screen:

• L/R arrow keys to move forwards or backwards a week at a time.

• Ctrl+L/R to move forwards or backwards a month at a time.
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• Ctrl+J or Go To > Date or 3rd CBA button jumps to a specific date.

• Space bar or Shift+Ctrl+J or Go To > Today to return to ‘today’.

And in Category screen:

• L/R arrow keys to move L/R through the categories.

• Next and Prev (2nd and 3rd CBA buttons in Categories screen) allow you to switch annual 
periods.

• Ctrl+B or Space Bar returns you to the current period.

Note: The joystick/navigation button can also be used instead of the arrow keys.

File Handling
The File menu gives the options for maintaining a number of different VacTrac files (maybe for 
multiple companies):

• Create file. This builds a new file with no people entered.

• Open file. This switches between files if you have more than one.

• More > Rename file. To change the name of the current file.

• More > Delete file. Deletes a file if no longer required (you cannot delete the current open 
file).

Under More > there are also options to Backup and Restore data. These are covered under 
different Help topics.

Managing People
Use the options in the People menu to define the personnel for recording leave. Use Add and 
complete the following details:

• First name and Last Name

• Department

• Phone

• Information

The personal details can subsequently be Updated or Deleted.

If you wish to change the order of the names in the display, use the Move option and specify the 
new line position.

Finally, the person’s details are available for quick view with the Details option.

Managing Leave Entries
Use the options in the Leave menu to record leave dates as they occur for individual people. 
Use Add, the 2nd CBA button, or simply the Enter key, and complete the following details:

• From and To dates of the leave period.

www.rmrsoft.com page 4



 RMRVactrac (for Nokia Communicators) Employee Leave Tracker

• Category (see separate Help topic for defining Categories).

• Notes for any optional text.

The leave will then be displayed in the Dates screen using the colour defined by the selected 
Category and with text showing depending on the View > Leave Label selection. This defaults 
to the Symbol.

Example Symbol Example Text

Entries can subsequently be Updated or Tab key, or Deleted or Del key.

If more than one leave period is shown on the screen (or you are using the options from within 
the Category screen) then a drop down menu is displayed so you can select which leave period 
to action.

Public Holidays
As many Companies do not count Public Holidays as part of the annual vacation allocation it is 
important that these holidays are shown and taken into account in calculations.

To add a Public Holiday use the Public holiday > Add from the Leave menu and complete the 
following details:

• Date of the holiday

• Description of the holiday (for information only)

• Symbol to be shown on the screen

• Repeat annually to differentiate between regular holidays and one-off holidays.

The holidays will be shown on the screen in the colour defined for Public Holidays in View 
preferences (and see separate Colour Picker Help topic), and apply to all people.

For each Category (see separate Help topic) you will specify if Public Holidays should be taken 
into account during calculations in the Category screen.

Use the Public Holiday > Delete from the Leave menu to delete a Public holiday from screen.

Purging entries
Although a large number of entries can be stored, it is good practice to regularly purge old 
entries. The files will be compacted at the same time to improve performance.

Use Purge old entries from the Leave menu, and specify the date before which all entries are 
removed.
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Using categories
The program uses categories to differentiate between types of holiday/vacation or sick leave. 
There are 4 pre-defined leave categories: Annual, Sickness, Maternity and Paternity. You 
can then add additional categories as required (example for Training or National Service). Use 
Add from the Category menu, and complete the following details:

• Label. Used to describe the Category and will also be shown on screen if the appropriate 
option is selected on the View > Leave label menu option.

• Symbol. This is a single character to be shown on screen if the appropriate option is 
selected on the View > Leave label menu option.

• Default start value. This specifies the number of days that an individual is given at the start 
of a period. For example, many Companies offer employees 30 days Annual leave.

• Work days only. This option specifies if non-working days (as defined in Control Panel) 
should be excluded from calculations of leave balances.

• Skip public holidays. This option specifies if Public Holidays should be excluded from 
calculations of leave balances.

• Carry forward (CF). This option defines if employees are allowed to carry forward any 
unused days of their allowance into the next annual period.

• Maximum CF value. Assuming Carry forward is allowed, this allows you to specify the 
maximum number of days allowed.

Colours (3rd CBA Button) allows you to specify the colour for the category (see separate 
Colour Picker Help topic).

Categories can be Updated or Deleted.

In the Categories screen there are additional commands in the Category menu. Move allows 
the category columns to be reordered horizontally. 

Modify initial entitlement changes an individual’s start value because of special 
circumstances.  There is also an option to do that globally across all people.

www.rmrsoft.com page 6



 RMRVactrac (for Nokia Communicators) Employee Leave Tracker

Other functions

Filtering entries
Use the Filter option from the Tools menu to activate a filter. Simply enter the search text 
string.

The display will then show only those people whose details (First name, Last name, 
Department, Phone and Information) contain the search string.

A filtered display will have an “(F)” in the Name column title. Press <Esc> to cancel the filter.

Export report
Use Data > Export report to export the full details of leave entries as an ascii text file in Tab 
delimited or CSV (Comma Separated Variable) formats. This can then be copied from your 
communicator for use in other PC programs, or used within the built-in applications.

Import the text file into a Word file, select all the text, then use 'Copy & Paste' functions to 
transfer them into a Sheet file for further manipulation.

Note that the data exported is for the people shown on the screen and the selected period. If 
you wish to limit the people to, for example, one department, then use the Filter option (see 
separate Help topic) to limit the people shown. If you wish to export a different period then 
ensure that period is displayed first. 

Memopad
The Memopad feature in the View menu allows you to keep any notes about people or their 
leave.

Password
Individual files can be Password protected. Use the Password option in the File menu:

• Turn the Password set to On.

• Enter the character string in the New password field and repeat it in the Confirm password 
field.

Passwords are case sensitive.

When a password is set you will be asked to enter the code when starting the program or when 
switching to the file from an unprotected file.

To remove a password use the Password option again:

• Enter the current Password to gain access.

• Leave Password set to Off.

• Leave the New password field and Confirm fields blank.
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Colour picker
When defining Categories, or specifying colours for various aspects of the display, within View 
preferences, the RMR Colour picker is used.

• The 16 basic colours can be selected by using the 0-9 & A-F keys.

• More subtle colours can obtained by selecting Red (Ctrl+R), Green (Ctrl+G) or Blue 
(Ctrl+U) (or use cursor key/joystick to select them) and then the L/R arrows to 
increase/decrease hue. The Shift key modifier will change increments more rapidly, and 
the Ctrl key modifier takes the setting to 0% or 100%.

• The Value CBA button allows you to specify the colour manually by absolute 0-255 RGB 
values.

• The Initial CBA button reverts to the original default colour.

Backup and Restore
Under the Data menu there are Backup data and Restore data options.

Backup data Shift+Ctrl+B allows you to manually keep a copy of your data elsewhere on the 
system for security. The set of backed up data files is stored in the:
Communicator:\My Files\RMR\Backups\RMRCar\  folder on the 9300/9500, or
Communicator:\System\Apps\RMRCar\Backup\  on 9210/9290.

Use the Backup options in General preferences to enable regular automatic backups of your 
data, or to change the location of the backed up files.

If necessary use Restore data Shift+Ctrl+R to restore all datafiles in the case of data loss.

Note: All current data in the program will be overwritten by restoring the backed up data.

Configuring the program
View preferences has some basic options for configuring the display. The following can be set:

• Font. To Arial or Times Roman.

• Date format. Gives a choice of various international date formats.

• Name column width. Allows you to define the width of the people name column.

• Display. Gives a choice of displaying first name only, last name or both.

• Info window. Gives a choice of narrow or wide for the Info window.
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For Colours (3rd CBA button), this opens a separate dialog where the colours can be specified 
for the header days and dates, Today, Public Holidays, and non-working days. Accessing these 
will invoke the Colour Picker (see the separate Help topic).

General preferences has other options for configuring the operation of the program. The 
following can be set:

• Start Day and Month. The program defaults to 1st Jan for the start of the annual accounting 
period. These allow you to select another date if your Company uses a different period.

For Backup (3rd CBA button):

• Auto. Select if you want a backup to be automatically carried out, and if so, how often.

• Start Date. When you want the autobackup to start.

• Prompt. Whether you want to be prompted for the backup.

• Location (Command Button). The location of the backup files can be changed from the 
default.

In the View menu there are also options for Switch title to remove the screen title, and Full 
screen to remove the information and button bars for more screen space. Four sizes of text are 
available with the Zoom option.

Author: RMR Software Ltd. (FAR)
Date:14 Feb 2006

Version: 1.0
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