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END USER LICENCE AGREEMENT 

All software products from RMR Software Limited are made available under the terms of the "End User 
Licence Agreement" (EULA) set out in the following sections. 
 
Notice to users: Carefully read the following legal agreement. Use of the software provided with this 
agreement (the "SOFTWARE") constitutes your acceptance of these terms. If you do not agree to the terms 
of this agreement, promptly remove the SOFTWARE together with all copies from your computer. User's use 
of this SOFTWARE is conditional upon compliance by user with the terms of this agreement. 
 
The software is protected by copyright law and international treaty provisions. You acknowledge that no title 
to the intellectual property in the software is transferred to you. You further acknowledge that title and full 
ownership rights to the software will remain the exclusive property of RMR Software, and you will not acquire 
any rights to the software except as expressly set forth in this licence. You agree that any copies of the 
software will contain the same proprietary notices which appear on and in the software. 
 

GRANT OF LICENCE 
 
This RMR Software Licence Agreement ("Licence") permits you to use one copy of the RMR Software product 
downloaded, which may include user documentation provided in electronic form ("SOFTWARE"). The 
SOFTWARE is licensed to a single user. The SOFTWARE or its component parts may not be separated for 
use by more than one user at any one time.  However, you may install the SOFTWARE on more than one 
computer, provided it is solely for the use of the licensee. 
 

REVERSE ENGINEERING 
 
You agree that you will not attempt to reverse compile, modify, translate, or disassemble the software in 
whole or in part. 
 

DISTRIBUTION 
 
Webmasters, platform manufacturers, dealers, distributors, agents, publishers or any other third party are 
permitted to copy or distribute the SOFTWARE, provided it remains in the same format as the product 
available from the RMR Software Web Site.  It is NOT permitted to copy or distribute any of the component 
parts of the SOFTWARE. Establishing an Internet link to the RMR Software web site is permitted, and is 
encouraged, in order to facilitate access to the SOFTWARE. 
 

COPYRIGHT 
 
The SOFTWARE (including any images and text incorporated into the product) is owned by RMR Software 
and is protected by copyright laws and international treaty provisions. 
 

LIMITED WARRANTY 
 
To the maximum extent permitted by applicable law, RMR Software disclaims all warranties, either express or 
implied, including but not limited to warranties of merchantability and fitness for a particular purpose. In no 
event shall RMR Software or its suppliers be liable for any damages whatsoever (including, without limitation, 
damages for loss of business profits, business interruption, loss of business information, or other pecuniary 
loss) arising out of the use or inability to use this RMR Software product. 
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Introduction 

RMRDiet is a user-friendly but powerful program for Palm OS® handhelds that will aid you in 
tracking your food and calorie intake, your exercise and calorie expenditure, and your overall 
weight loss or healthy eating program. 

Disclaimer 

Before starting any diet, weight management or exercise program, it is advisable to consult your 
doctor.  The instructions and advice given here, and the use of this program, are in no way 
intended as a substitute for medical counselling. 
 

Program Setup 

When you start the program for the first time you will be guided 
through a series of screens prompting you for… 

Unit preferences 

The Height units, Weight units, and number of Decimal places you 
wish to use. 

User details 

Enter your Name, Sex, Birth date, Height, current Weight, and the 
Activity level that best fits your lifestyle from: 

sedentary - a quiet life mainly sitting 
light active - mostly desk work and travelling in a vehicle 
moderate active - some physical work activities or occasional 

exercise 
very active - demanding physical work or exercise several 

times per week 
extra active - extremely physical activities. 

Targets 

Enter your Goal weight and select the amount of weight you want 
to lose per week. From these the program will calculate the 
number of weeks it will take to meet your goal, and your required 
Daily calories - the two values show how many calories you need 
to: 

maintain current weight / change to target weight. 
In addition set the type of diet that you want to follow with the 
C/P/F ratio (Carbohydrate/Protein/Fat).  To maintain a healthy diet 
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you need to obtain calories from a mix of these different sources.  
Choose from 6 different diet types from 80-10-10 vegetarian 
through to 40-30-30 zone diet.  Each of these gives pre-
determined nutrient breakdown targets for: 

Calories Carbohydrates 
Total fats Fiber 
Cholesterol Sugar 
Sodium Protein 

which are listed in the bottom half of the screen. 
 
If you want to change the calorie target for your total daily intake, 
enter a new value in the Calories field and tap the  button next to 
it - all other nutrients fields will be recalculated using the defined 
C/P/F diet type.  The  next to the Daily calories field will copy the 
calculated calories value back to the Target Calories field. 
 
You only need to set up these user details and targets once, but 
you can change the settings at any time through the Options 
menu. 

Screen views for adding data 

Now you can start adding your data, which you need to do 
regularly. Note that there are 3 different screens accessed from 
the View menu, or directly from the Diet, Weight and Exercise 
tabs at the top of the screen. Select the appropriate view to add 
your food, weight and exercise details. 
 

The date is also shown here, which defaults to 'today', but can be 
changed with the < or > buttons if you need to make entries or 
view the data for other dates. 
 
In all the Add screens there is a Time selector which you can use 
to accurately record the time of eating, weighing yourself or 
exercising. 
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Diet Tracker 

Use the Diet screen to record and analyze your food intake. 

Time views 

Along the bottom of the screen are 8 tabs.  The first 6 of these 
subdivide the day into meal periods for: 

B – Breakfast A – Afternoon 
M – Morning D – Dinner 
L – Lunch E – Evening 

When you want to record food eaten, select the tab for the 
appropriate period and use the Add button. 

Add food 

In the Add screen you have tabs that give the option of adding 
Food from the supplied database, or from Menus or Recipes which 
you create yourself to automate the food recording process (see 
later). 
 
To add a single food select the Food tab.  Browse for the food by 
navigating through each of the dependent Category, Name and 
Type lists.  Alternatively type the name of the food (e.g. milk) in 
the Name or Type field and press the Find button, then select the 
appropriate one from the displayed list. 
 
Next either accept the given Serving size and Serving unit, or 
change the value and select a new unit from the drop-down list 
(ml, tsp, tbsp, fl oz, cup, pt, qt).  The  button will recalculate the 
Nutrients values below for the new serving size. Finally tap the OK 
button to enter the food details, when it will appear in the list for 
that day and time period.  Use the All tab to view a log of all the 
food you have eaten in the day. 

Screen display 

Note that you can tailor the screen display to your requirements.  
Tapping on the column heading titles allows you to select which of 
the recorded details are shown: 

Date Calories Fiber 
Time Total fat Sugar 
Meal Cholesterol Protein 
Food Sodium 
Size Carbohydrate 

The column separators themselves can be dragged to a suitable 
width for the values. 
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At the bottom of the screen a coloured progress bar shows your 
consumption for the period compared to your target value.  
Adjacent are three values (e.g. 681/1769/ 38%) giving: 

current total / target intake / percentage consumed. 
By default these show the Calories, but you can select any of the 8 
nutrients. 
 
By selecting Show/Hide graph from the View menu, or tapping on 
the half arrow on top right of the list screen, you can reduce the 
size of the list to show all of the 8 nutrient graphs at the bottom.  
View these after you have recorded individual foods, meals or a 
whole day's intake, to check your overall calorie and nutrient 
intake and make judgements as to whether you are getting a 
balanced diet or need to increase/decrease foods in certain areas.  
The graphs will change to red if you exceed your target. 

Add new foods 

If the provided database doesn't contain your favourite foods, you 
can add your own.  Use the Options menu to view the Foods list, 
or use the New button in the Add Food screen.  Select the correct 
Category, tap in the Name field and write in the name of the new 
food, and then do the same for the Type field.  Correct the Serving 
size, Units, Serving in gm or ml value, and all the nutrient details, 
and then tap on the Save button.  It will then be available for 
selection next time you Add Food in the Diet screen. 

Create Menus and Recipes 

Menus and Recipes allow you to automate the food recording 
process by entering a collection of foods as a single entry.  A 
menu is typically an entire meal, while a recipe is several foods 
combined together to make other another food. 
 
To create an example Menu use the Options menu to view the 
Menus list.  Select a meal from the 6 day periods (e.g. Lunch), and 
tap on the New button to give the menu a Name (e.g. lunchbox), 
then add a food using the normal selection process.  Repeat this 
using the Add food, Edit food and Delete food buttons as required 
to build up the contents of a meal that you have regularly (e.g. 
bread, ham, soda, chips, candy bar, apple), and then tap the Done 
button when complete. 
 
Now you will be able to select the name of your meal in the Add 
Menu screen, and enter all these foods in one go. 
 
The same principle applies to creation of Recipes, but for these 
you would typically build up a list of cooking ingredients. 
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Weight Tracker 

Use the Weight screen to keep a record of your weight loss (or 
gain!). 

Add weight readings 

Use the Add button, select the Date and Time, and enter your 
current Weight.  If you wish you can also record your Body 
measurements to track these. 
 
Finally tap the OK button to enter the details, when the dated and 
timed entry will appear in the list, showing the Weight and Weight 
change from your original starting point. 

Screen display 

As before, tapping on the column heading titles allows you to 
select which of the recorded details are shown 

Date Chest Forearm 
Time Waist Thigh 
Weight Hips Calf 
Weight change Bicep Bodyfat 

 
The column separators themselves can be dragged to a suitable 
width for the values. 
 
At the bottom of the screen a coloured progress bar shows your 
weight change compared to your starting weight on the left and 
target weight on the right.  Additional values (e.g. /4/50%) are 
given for the: 

/ weight remaining to reach the target / percentage achieved 
so far. 

The bar will change to red when you exceed your weight target. 
 
After a longer period of adding data, tapping on the Display 
selector at the bottom left of the screen allows you to filter the 
entries to see only the details for various time periods. 
 
By selecting Show/Hide graph from the View menu, or tapping on 
the half arrow on top right of the list screen, you can reduce the 
size of the list and show a line graph of your weight instead of the 
bar. 
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Exercise Tracker 

Use the Exercise screen to record and analyze your exercise 
program. 

Add exercise activities 

Use the Add button to bring up the Add screen where there are 2 
tabs for adding Exercises from the supplied database, or for 
Routines which you create yourself to automate the recording 
process (see later). 
 
Select the Exercise tab and browse for the exercise by navigating 
through each of the dependent Category, Name and Type lists, 
and then use the hour and minute selectors to record the length of 
time you spent doing the activity.  The Total calories burned by this 
exercise will be calculated at the bottom of the screen. Finally tap 
the OK button to enter the exercise details, when it will appear in 
the list. 

Screen display 

Note that you can tailor the screen display to your requirements.  
Tapping on the column heading titles allows you to select which of 
the recorded details are shown: 

Time 
Exercise 
Exercise time 
Calories burned 

 
The column separators themselves can be dragged to a suitable 
width for the values. 
 
At the bottom of the screen the Intake values show your: 

current total / target intake / percentage consumed 
calories for the day, copied from the Diet screen. 
 
Under this are the Burned calories resulting from your day's 
exercise shown as a coloured progress bar. The three numeric 
values show: 

calories burned today / 
calories needed to burn to achieve your weight target / 
percentage of the first over the second. 

The bar will change to red if your calories burned total exceeds 
your calories needed. 
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Burning calories 

To explain further the “calories needed to burn to achieve your 
weight target”.  On the Target screen you calculated or entered the 
daily intake calories required to reach your weight goal in xxx 
weeks, for your selected activity level.  This means that without 
any additional exercises you would normally achieve the goal in 
xxx weeks if you eat exactly the "daily intake calories".  If you eat 
more than this, you will need to take additional exercise to reach 
the goals, as this example sequence indicates: 
 
For a daily intake target of 2000 calories, you can eat 2000 
calories before you need to perform exercise.  At the start of the 
day the bar will show these calories needed to burn as negative. 
 
After eating a lunch of say, 600 calories, you still don't need 
exercises, but the calories needed to burn has reduced to –1400. 
 
For an afternoon snack you overeat 10 pieces of cheese cake = 
1800 calories.  Oops! - you exceed your daily intake needed by 
400 calories (-1400+1800). 
 
Time to exercise! Your target exercise value is 400 calories to 
compensate for the extra food eaten. You jog at 7min/mile for 10 
minutes = 331 cals. This adds to the calories burned today value, 
with the bar showing the progress and giving 82% of that needed. 
 
You walk fast for 30 minutes = 294 calories.  The calories burned 
today value becomes 625 (294 + previous 331) which now 
exceeds the 400 needed, and the bar turns red as it is over 100%.  
You burned all the calories you have to, and even more. 
 
You now need to eat again (to reach the target goals). 
 
By selecting Show/Hide graph from the View menu, or tapping on 
the half arrow on top right of the list screen, you can reduce the 
size of the list to show a running daily bar graph of your calories 
burned. 

Add new activities 

If the provided database doesn't contain your favourite sports or 
exercises, you can add your own. Use the Options menu to view 
the Exercise list, or use the New button in the Add Exercise 
screen.  Select the correct Category, then as appropriate, tap in 
the Name field and write in the name of a new exercise, and then 
do the same for the Type field.  Add the MET (metabolic) 
equivalent value for this exercise, then tap on the Save button. It 
will then be available for selection next time you Add exercise. 
NOTE: 
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METs are a way of expressing rate of oxygen utilization and hence 
calorific burn.  One MET is the rate when your body is at rest 
(sitting quietly).  An activity that uses oxygen at twice the resting 
rate is equal to 2 MET, and so forth.  The MET level will stay the 
same as long as you do not change the intensity with which you 
are working. 

Create Routines 

Routines allow you to automate the exercise recording process by 
entering a collection of activities as a single entry.  To create an 
example Routine use the Options menu to view the Routines list.  
Tap on the New button to give the routine a name (e.g. morning 
exercise), then add an exercise using the normal selection 
process.  Repeat this using the Add exercise, Edit exercise and 
Delete exercise buttons as required to build up the contents of 
your regular routine (e.g. warm up 5mins, walking 10 mins, jog 30 
mins, walk 10 mins), and then tap the Done button when 
complete.  Now you will be able to select the name of your routine 
in the Add Routine screen, and enter all these activities in one go. 
 

 
© RMR Software 
[Last Updated : Dec 2001] 
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