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RMRData: Quickstart 
RMRDATA is a database program designed to hold records of all your financial accounts, pin 
numbers, logins, passwords, and other personal information in a secure fashion. The basic idea 
is that you create Entries and group them together under various Types (Bank Accounts, 
Credit Cards, Passport Details etc). The Details of each entry can then be displayed in 2 
different ways. 

The first method is with the Card view where selected details are shown as though on a credit 
or membership card (centre screen view above). You access this view through the RMRData > 
View menu, or by tapping on the Card icon on the bottom bar.  For security purposes the PIN is 
initially blanked out, but you can expose the PIN number of the card by tapping on the gold 
area. Exit this view by tapping anywhere else on the screen. See the Using Cards section for 
more details on how to design and name different card formats and how to link them to each 
Type. 

The second method of viewing the details is through the Details option in the RMRData > View 
menu. The right hand screenshot above shows how the details are presented on a scrolling 
screen. 

At the bottom of the screen a button bar has a series of buttons for quick actions (from left to 
right): 

 - view Card for entry 
 - view Details for entry 
 - view Memo for entry 
 - Add new entry 
 - Update entry 
 - * user defined action (set in General Preferences) 
 - 4-way scroll arrows. 
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You can have multiple databases, each of which can be renamed or deleted, and you can apply 
three levels of security: None, Password controlled, or fully Encrypted. 

A full set of Import/Export options are provided, and an automatic or manual Backup/Restore 
facility is also implemented. Finally a Find function allows you to quickly access an entry. All 
these functions are described later in this Manual. 

Moving around entries and files 
There are various shortcut methods for moving around the screen. 

• Tap on a Type or Entry to select it. 
• Tap on the Up/Down arrows on the 4-way scroll button to move a screenful at a time. 
• Tap on the Left/Right arrows on the 4-way scroll button to cycle round your 

Data files. 
• Jog-dial up/down scrolls the highlight. 
• Push in jog-dial acts as ‘select’. 
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Using Databases 
The RMRData menu gives the options for maintaining a number of different databases: 

• Use Create database to build a new database with a number of pre-defined types and 
a couple of example entries that can be amended or deleted. The given name for the 
database will be shown in the bottom window. 

• Open database switches between databases (this option will be greyed out if you have 
only one database). 

• Use Database > Delete to delete a database if no longer required. (Note that you 
cannot delete the current database so if you wish to do that you must switch to another 
database). 

• Use Database > Rename to change the name of the current database. 
• Use Database > Encrypt occasionally if you have made a large number of changes to 

remove unused space and reduce the memory requirements. 

There are also options to Import and Export databases and to Backup and Restore 
databases. These are covered in specific sections later in the manual. 

Security 
For each of your databases you can apply three different levels of security: 

1. Insecure (the default when you started). No security is applied, and the program can be 
freely opened. 

2. Password controlled only. This stops casual viewing of the data, although it is still stored 
on the Communicator disc in a format that could be viewed with a text editor. 

Use the RMRData > Password option to protect individual databases as required. 

• Turn the Password set to On. 
• Enter the character string in the New password field and repeat it in the Confirm 

password field. 

Note: Passwords are case sensitive. 

You can decide how frequently the Password dialog is shown and you are asked to enter the 
code, with the appropriate options in General preferences > Password button. These can be 
turned on/off when Starting the program, Switching databases, Switching to the program, and 
Opening the phone. 

To remove a password use the Password option again: 

• Enter the current Password to gain access. 
• Leave Password set to Off. 
• Leave the New password field and Confirm fields blank. 
 

3. Encrypted. This is the most secure level. The data is scrambled as it is stored on disc, 
using an encryption algorithm based on the Password. This makes it impossible to read the 
data. Use RMRData > Database > Encrypt to set or clear the encryption. Because the 
password is used to encrypt the data you will not be allowed to encrypt any database 
without a password being set first. 
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Note: If you forget the password for an unencrypted database we can probably recover the 
data. However, if you forget the password on an encrypted database you will NEVER be able to 
recover the data, so make sure you use something memorable or keep a record elsewhere! 

Backup/Restore 
Under the RMRData > Database > menu there are Backup and Restore options. 

Backup database allows you to manually keep a copy of your data elsewhere on the system 
for security. The set of backed up data files is stored in the: 
C:\Documents\Media Files\Document\RMRBackups\ folder so that you can access them 
through a PC. 

Use the Backup options from the button in General preferences to enable regular automatic 
backups of your data. 

If necessary use Restore to restore all datafiles in the case of data loss. 

Note: All current data in the program will be overwritten by restoring the backed up data. 
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Using Types 
Types are the top level categorization in a database for information of the same type (Bank 
Accounts, Credit Cards, Passport Details etc), and are listed in the first screen column. The 
default database gives you several pre-set entries as an example, but you can delete or amend 
these, or create different ones to suit your needs.  

The options in the Edit > Types menu allow you to modify the types: 

• Use Add to create a new Type. In the first dialog enter a Name and specify which, if 
any, Card display format you wish to use. Then use the Fields button to define the 
titles to be used for the individual details fields. 

• Use Update to modify an existing Type. This is similar to Add, allowing you to change 
the Name, the associated Card format and the Field titles. 

• Use Delete to remove any unwanted types. Note that you can only do this if there are 
no associated entries. 

• Use Move to rearrange the order of the types listed in the display. 
• There are also options to Import and Export Types. These are covered under specific 

sections later in the manual. 

Entries 
Entries are your individual records with your details filed under the Type categories. The default 
database gives you a few example entries to show the principle, listed in the second screen 
column as you scroll down the Types.  

The options in the RMRData menu allow you to modify the entries: 

• Use Add entry, or the Add button at the bottom to create a new Entry. In the first dialog 
enter a Name and specify which Type it belongs to. Then use the Details button to 
enter the information for each of the specified fields. 
While in this dialog, the button marked Colour allows you to specify the Background of 
the Card display. Tap on the appropriate slider bar to adjust the ‘hue’. The button 
marked Memo allows you to add a note for the entry. 

The fields accept free-format text so you can enter dates or numbers as text for complete 
flexibility. 

• Use Update entry or the Upd button to change an existing Entry. This is basically the 
same as Add above, allowing you to change the name, the type, the background colour 
of the card and the information. 

• Use Delete entry to remove any unwanted entries. 

Additional functions are in the Edit > Entries menu. 

• Use Duplicate to create a copy of an existing entry when you have similar details to be 
entered. 

• Use Move to rearrange the order of the entry listing in the display. 
• Use Sort to rearrange the entry listing into alphabetical order. 
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Using Cards 
The Card format view shows the details for an Entry in a ‘real world’ way as though on a credit 
or business type card (see screenshot in the Overview). View the card with RMRData > View > 
Card menu option, or the Card button at the bottom, or by tapping on a selected entry 
(configurable in General preferences). All Types of Entries can have a card view chosen from 
a small library of card display formats, or you can design your own card with the options in the 
Edit > Cards menu: 

• Use Add to create a new card. In the first dialog specify the Name of the card and the 
Number of lines of text you wish to display on it. Use the Lines button to define which 
field should be shown on each line of the card, allowing you to rearrange the order of 
the information if necessary. Use the Icon  button to insert a specific icon on the Card 
display. (Remember the background colour is specific to an entry so is set in the 
Add/Update Entry dialogs). 

Note: These are the icons available at the moment. If any user wants to add to the selection 
simply send us the icon for inclusion in the MBM file. The icons need to be 40 x 40 pixels x 256 
colours please. 

• Use Update to change an existing card. This is similar to Add above, allowing you to 
change the name, the width, the lines and the icon. 

Note: that because of its complexity, the Credit Card design is fixed and cannot be changed. 

• Use Delete to remove any unwanted cards. 

Once a card format has been designed, you can allocate it to a Type using the Edit > Types > 
Update menu option. 
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Other Functions 

Find 
The Edit > Find menu option allows you to jump quickly to an entry. Simply enter the text 
required and the first entry that contains that text will be displayed. 

Then use Edit > Find > Find next to continue searching through the entries. 

Import & Export 
There are various Import and Export options, all of which work in TAB-delimited or Comma 
Separated Variable (CSV) format text files. 

1. Import in the Edit > Types menu. Use this to import Types to the database if you want to 
design the Types off-line. To see the import format required, simply perform an export on the 
default types and use that as a template to build your own. 

2. Export in the Edit > Types menu. Use this to export the Types so that they can be 
viewed and/or edited in a text editor/word processor (TAB delimited format) and spreadsheet 
program (CSV format). 

3. Import database in the RMRData > Data menu. Use this to import Entries into the 
database. Again, to see the import format required, simply export the default types and use that 
as a template. 

4. Export database in the RMRData > Data menu. Use this to export Entries from the 
database to be viewed and/or edited in a text editor/word processor (TAB delimited format) and 
spreadsheet program (CSV format). You can choose to export All entries or just those from the 
Selected type. 

At the request of Steve Litchfield (3-lib) the Database import and export also has an additional 
mode called Text which outputs each field on a separate line. This is based on the export 
format used by Handy Safe, so it should be possible to import databases previously exported 
from this program. Obviously it will not be 100% perfect, as we disagree with some of the field 
titles used by Handy Safe, and also we had to assume the default values and icons in Handy 
Safe as well. So if you have changed any of the defaults then the Entries may be imported 
under a different Type name, but any differences can be very quickly fixed after the entries have 
been imported by using Edit > Types > Update and RMRData > Update entry to change the 
type and/or fields. 

Note: you cannot Import to an encrypted database, so you will have to unencrypt the database, 
then carry out the Import, then Encrypt again. 

Note: Export will produce an unencrypted text copy of the database, so due care should be 
taken. 

The exported files will be stored in the C:\Documents\Media Files\Document\RMRExport\ folder. 

Memopad 
The memopad feature allows you to record any notes about an entry that is not covered by the 
Type headings. 
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This memo can be created or viewed by using the RMRData > View > Memo menu option, or 
by using the Memo button at the bottom, or by tapping a previously selected entry (depending 
on the selection made in the General Prefs). 

An entry that has a Memo attached will be shown by an additional (‡) symbol after the Entry 
name. 

Miscellaneous 
Zoom in/out – change the font size of the display. (Not implemented because of a problem with 
the Symbian OPL Runtime code). 

About– an information screen with details of the program. 
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Configuring RMRDATA 
The program is extremely configurable so you can change many settings to suit your way of 
operating. 

View Preferences 
The View preferences options allow you to configure: 

• Font type allows Arial or Times Roman. 
• Change the Header window colour, 
• Type column % allows you to adjust the widths of the columns to suit the text. 

The button marked Card accesses the colour picker to set the default card colour. 

General Preferences 
The General preferences options allow you to specify: 

• the action you want the User Button on the bottom screen to carry out - either Find, 
Backup or Compact the database. 

• the action you want the carried out if you Tap on selected entry - either display the 
Card, Details, or Memo for the selected entry or Update it. 

The button marked Password allows you to specify when the Password dialog should be used 
to prevent the database from being opened directly for viewing, and can be set when starting 
the program, switching database, switching program, and opening the phone. 

The button marked Backup allows you to specify the automatic backup options: 

• Auto turns on the automatic backup, and sets the frequency to Daily, Weekly or 
Monthly. 

• Start date when you want the first backup to run. 
• Whether a Prompt is required. 
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